Firma » Biznes

Funkcje informacyjne w analizie Excelowej

Funkcje informacyjne mogą być pomocne przy analizowaniu dużych baz danych, gdzie wyświetlenie wybranej wartości dla konkretnego błędu może znacząco przyspieszyć prace analityczne. Poniżej kilka przykładów funkcji przydatnych w pracy analityka.

1. NR.BŁĘDU

Zastosowanie tej funkcji pozwala na wyświetlenie wartości błędu w programie Microsoft ExcelDobrym przykładem zastosowania funkcji NR.BŁĘDU jest połączenie jej z funkcją JEŻELI w celu wyszukania odpowiednich wartości błędów i przypisaniu im zadanych przez użytkownika komunikatów. 

 

Przykład funkcji: =NR.BŁĘDU(A1)

 

Jeżeli w komórce A1 będzie błąd, Excel wyświetli odpowiedni numer błędu (zgodnie z poniższą tabelą). Jeżeli w komórce nie będzie błędu, jej wartość będzie równa #N/D!

 

Numery błędów:

• #ZERO! - 1
• #DZIEL/0! - 2
• #ARG! - 3
• #ADR! - 4
• #NAZWA? - 5
• #LICZBA! - 6
• #N/D! - 7
• #POBIERANIE_DANYCH - 8
• Inne - #N/D!

 

2TYP

Funkcja TYP pokazuje typ wartości i jest bardzo przydatna jeżeli kolejne funkcje są powiązane z typem wartości w wybranej komórce. 

Przykładowa funkcja to:

= TYP(A1)

 

W zależności od wartości, funkcja TYP wyświetla: 

• Liczba - 1
• Tekst - 2
• Wartość logiczna - 4
• Błąd - 16
• Tablica - 64

 

WAŻNE: Funkcję excelową TYP można stosować z komórkami, w których znajdują się formuły, ale mając świadomość, że będzie się ona odnosiła do wyniku obliczeń formuły.

 

3KOMÓRKA

Funkcja pokazuje informacje o położeniu, zawartości i formatowaniu komórki. 

Przykładowa funkcja wygląda tak: KOMÓRKA(typ_info;[odwołanie])

gdzie typ_info  to wartość tekstowa, która mówi jakie informacje o komórce wyświetlą się użytkownikowi

Poniżej najbardziej przydatne typy informacji, które można wyświetlić:

• kolumna - numer kolumny, w której znajduje się wybrana komórka, 
• wiersz - numer wiersza, w którym znajduje się wybrana komórka, 
• adres  adres wybranej komórki np. $A$1, 
• zawartość  wyświetla wartość komórki zamiast np. formuły, 
• nazwa_pliku  pokazuje pełną nazwę pliku ze ścieżką, gdzie zapisany jest plik (włączni z arkuszem), 
• typ - wartość komórki odpowiadająca typowi danych, „b” jeśli „blank”, „l” jeśli komórka jest pusta, „v” jeśli w komórce jest inna wartość. 

 

Przykładowo, żeby przed wykonaniem obliczeń na komórce (np. pomnożenie razy 10) chcemy sprawdzić, czy zawiera ona wartość liczbową, a nie tekst, można wpisać następującą formułę:

= JEŻELI(KOMÓRKA("typ";A1)="v";A1*10;0)

 

Obliczy ona wartość A1*10 tylko w przypadku, gdy w komórce A1 jest liczba. Jeżeli w komórce jest tekst lub nie ma nic, formuła domyślnie przypisze wartość 0.

 

Autorem tekstu jest wyszukjapionowo.pl



Redakcja CentrumPR informuje, że artykuły, fotografie i komentarze publikowane są przez użytkowników "Serwisów skupionych w Grupie Kafito". Publikowane materiały i wypowiedzi są ich własnością i ich prywatnymi opiniami. Redakcja CentrumPR nie ponosi odpowiedzialności za ich treść.

Nadesłał:

Wyszukajpionowo

Komentarze (0)


Twój podpis:
System komentarzy dostarcza serwis eGadki.pl
Opublikuj własny artykuł
Opublikuj artykuł z linkami


Kalendarium

Przejdź do kalendarium »

dodaj wydarzenie »

Ostatnio dodane artykuły

dodaj artykuł »